Which Java version does Minecraft 1.18 require?

By on

Just a quick reminder that Minecraft 1.18 (Or "Cave and cliffs part 2") requires Java 17, which is another step up from Minecraft 1.17 requiring Java 16.

Here's a short history of Minecraft versions and their respective required Java version:

Minecraft Version Minecraft Releasedate Java version
1.0 18 november 2011 6 or 7
1.12 7 june 2017 8 (LTS)
1.17 8 june 2021 16
1.18 30 november 2021 17 (LTS)

LTS stands for "Long Term Support". These versions can get (security) updates for a long time after release, the general length seems to be 8 years.
(Java 6 & 7 were also supported for +/- 8 years, but this was before the term "LTS" was used)

There were 2 version changes in 2021 because Java 16 was not an LTS, and so was only supported for a few months. At the time of Minecraft 1.17's release, Java 17 was not out yet, so the decision was made to temporarily switch to Java 16.

Comments

Name
Email
Website
Body
Jelle De Loecker